№15.2 демо ОГЭ 2024 на Python

В задании 15.2 нужно написать программу, решающую указанную задачу.

Написать можно в том числе и на Python. Посмотреть, какое программное обеспечение было установлено на экзаменационных компьютерах в 2023 году можно, например здесь.

Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000. Введённые числа не превышают 30000.

Программа должна вывести одно число: количество трёхзначных чисел, кратных 4.

Пример работы программы:

Входные данныеВыходные данные
120
9
365
4
1
Демо ОГЭ 2024

Решение может выглядеть так (после # – комментарии к каждой строчке кода):

answer = 0 # объявляем переменную-счётчик, в которой будет результат, обнуляем её
a = int(input()) #  вводим первое число из последовательности
while a != 0: # тело цикла будет выполняться, пока не введём 0
        if (a % 4 == 0) and (a > 99) and (a < 1000): # проверка условия
                answer = answer + 1 # значение переменной-счётчика увеличится на 1
        a = int(input()) # ввод следующего числа из последовательности
print(answer) # вывод результата

Этого достаточно. Не требуется дополнительных проверок, например, на натуральность введённого числа.