Про учеников (Python). №16 ОГЭ

Варианты задания 16, формулировка которых отличается от ввода последовательности чисел.

Имена переменных могут быть другими.

№41E9E1

  • условие
  • решение

Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов.

Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ.

Пример работы программы:

Входные данныеВыходные данные
4
15
12
0
17
17
YES

contestants – количество участников викторины; best_result – количество правильных ответов у победителя; zero_result – есть ли участники, не давшие правильных ответов; result – количество правильных ответов конкретного участника.

Вводим количество участников, преобразуем в целое число (int()). Количество правильных ответов победителя сначала минимально, равно 0. При вводе результатов оно изменится. Первоначально считаем, что участников, не давших правильных ответов нет: zero_result = “NO”.

Организуем ввод данных в цикле по количеству участников. Также меняем значение результата победителя на большее, а если введён результат 0 – меняем значение переменной, сообщающей о наличии участников без правильных ответов.

Выводим ответы – значения переменных best_result и zero_result.

Вариант решения

contestants = int(input())
best_result = 0
zero_result = "NO"

for contestant in range(contestants):
    result = int(input())
    if result > best_result: best_result = result
    elif result == 0: zero_result = "YES"
    
print(best_result)
print(zero_result)

Теперь про зачёт по физике.

№87A333

  • условие
  • решение

На зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач. Сколько учеников получило зачёт? Вычислите среднее количество правильно решённых задач учащимися, получившими зачёт. Гарантируется, что хотя бы один ученик сдал зачёт.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых задач.

Пример работы программы:

Входные данныеВыходные данные
4
3
9
10
6
2
9.5

pupils – количество учеников в классе; passed – количество учеников, получивших зачёт; general_results – общее количество задач, решённых учащимися, получившими зачёт; result – количество задач, решённых учеником.

№15.2 ОГЭ про учеников(1)

И, задача про контрольную по алгебре.

№5A5C7A

  • условие
  • решение

На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.

Пример работы программы:

Входные данныеВыходные данные
4
3
9
2
8
2
NO

pupils – количество учеников в классе; failed – количество неудовлетворительных оценок; all_solved – наличие учеников, решивших правильно все задачи; result – количество правильно решённых примеров у конкретного ученика.

№15.2 ОГЭ про учеников(2)

Решения и их запись ориентированы на изучение Python по учебникам Босовой Л.Л., Полякова К.Ю.

Примеры из Банка заданий ОГЭ.