№15.2 ОГЭ. Наблюдения за погодой (Python)

Иногда формулировка задания 15.2 отличается от привычного ввода последовательности чисел. Рассмотрим такие задачи.

Имена переменных могут быть другими.

№C681D5

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите самую низкую температуру за время наблюдения. Если температура опускалась ниже –15 градусов, выведите YES, иначе выведите NO.

Программа получает на вход количество дней, в течение которых проводилось измерение температуры N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Пример работы программы:

Входные данныеВыходные данные
4
–5
12
–2
8
–5
NO

Пусть days – количество дней измерения температуры, min_temperature – самая низкая температура за время наблюдения.

days можно ввести через input() и с помощью int() преобразовать в целое число.

Чтобы упростить решение, присвоим min_temperature изначально большое значение, которое гарантированно изменится при сравнении с вводимыми данными. Это может быть и 1000, и 10000. Судя по условию, речь идёт об обычных учениках вполне земной начальной школы. Зная, что рекорд температуры на Земле не превышает 58 градусов, можно поставить значение 58. Но можно и больше.

Объявим также переменную cold, присвоим ей значение “NO”. Если будет введено значение температуры меньше -15, значение переменной изменится на “YES”.

После того, как значения этим переменным присвоены, организуем цикл, который будет повторяться заданное количество раз (переменная day будет меняться от 0 до значения (days – 1)) по введённому количеству дней измерений.

В теле цикла будем вводить дневную температуру, для этого объявим переменную temperature. Так же, как и количество дней, преобразуем её в целое число. Если введённое значение окажется меньше 15, изменим значение переменной cold. Заменим текущее значение переменной min_temperature, если введённое значение будет меньше его.

После того, как будут введены температуры заданного количества дней (тело цикла выполнится заданное количество раз), выведем значение минимальной температуры – min_temperature и опускалась ли температура ниже -15 – значение переменной cold.

Вариант решения

days = int(input())
min_temperature = 58
cold = "NO"

for day in range(days):
    temperature = int(input())
    if (temperature < -15):
        cold = "YES"
    if temperature < min_temperature:
        min_temperature = temperature 
         
print(min_temperature, cold)


№8E46D4

  • условие
  • решение

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру для дней, когда температура поднималась выше нуля градусов. Определите количество таких дней. Гарантируется, что за время наблюдения хотя бы в один из дней температура поднималась выше нуля градусов.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Пример работы программы:

Входные данныеВыходные данные
4
–5
12
–2
8
–5
NO
8E46D4

№A367FD

  • условие
  • решение

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.

Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

Пример работы программы:

Входные данныеВыходные данные
4
–4
12
–2
8
3.5
NO
A367FD

№15.2 демо ОГЭ 2024 на Python

Примеры из Банка заданий ОГЭ.